Jump to content

Recommended Posts

Hey guys! 

I was wondering why this game isn't yet registered on Nvidia. I open GeForce experience to try and get some optimization but the game isn't listed. I was wondering why on earth Jurassic Park sim gets support from Nvidia with day 1 updates but not you?

 

I ask this because I am currently only getting 40% usage with my 1070 meaning I only get around 35fps 

2018-10-23 (1).png

Share this post


Link to post
Share on other sites

runs pretty shitty for me on a 1070, when servers full im around 40-50 which feels shit on 144hz, fine when servers empty though haha, gpu usage is never past 40% and cpu never past 50%

  • Like 1

Share this post


Link to post
Share on other sites
19 minutes ago, OHSOJENSY said:

What are the other specs on your pc? I've got a 1070 and I'm getting 100fps. Only when streaming this game do I get below 80

 

I have 16gbs of corsair rgb vengeance ram.  I5 8400, 1070, Got the game on an SSD and am using latest drivers 

Share this post


Link to post
Share on other sites

Dang that's crazy to me.  I'm running similar ram, the only real difference is I have an i7, but I don't think that would make that much of a difference

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Jmdhainsworth said:

runs pretty shitty for me on a 1070, when servers full im around 40-50 which feels shit on 144hz, fine when servers empty though haha, gpu usage is never past 40% and cpu never past 50%

Same its really weird. Some friends I have can reach 60fps fine and they have a gtx 970 whilst I am getting worse. I feel like its random for everyone, like a 50/50 chance to get good or bad performance

Share this post


Link to post
Share on other sites

@chrashpilot you can use the fps counter from steam or Nvidia ... Ww3 doesn't have one integrated right now ... I think ^^

My game runs between 50-80fps constantly...

(High/ultra settings)

16gb ddr3 ram

Gtx970

i7-4790k

Ssd

 

Turning of motion blur could help 

 

Edited by Lykran
  • Like 2

Share this post


Link to post
Share on other sites

I got only around 30 fps in the beginning, everything on ULTRA. Changing these settings didn't have any effect at all.

Then I played around and just for fun enabled MOTION BLUR and the option below, something with FRAME LAG and now get a constant 60-100 fps. Don't know what it does but maybe try it?

on 1920x1080, i7-5960x, 64 GB DDR4, Geforce 980 GTX ti

  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much for your input. I will try it out just to see what my FPS are becaus it is running smooth on my 144Hz Monitor, so it is probably >75FPS. BTW I wrecked my Win10 installation with linux and now the AMD driver FPS overlay doesn't work anymore, too lazy to format and reinstall all the stuff... (I7 6700k, 16G Ram, XFX r9-390 DD blk edition with 8G vRam).

Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...