Jump to content
Dynshot

WW3 Optimization / Increase FPS Guide October 2018

Recommended Posts

WW3 Optimization / Increase FPS Guide October 2018: (Last Edited 10/23/2018)

This guide will help you use your computer to the max to play this amazing new game. In the future the game will be optimized but it's just the beginning now and not everyone has a $3000 system, so this might help a lot of people.

Step 1: Windows Optimization / Hardware Optimization

Install CCleaner and clean everything on your computer. This makes a lot of things fairly easier.

Install Driver Booster (Checks for New Drivers Easily all over your computer)

Optimize Windows 10 for Performance

  1.  Open Windows Explorer
  2. Right Click "This PC" and go to "Properties"
  3. Click "Advanced Settings"
  4. Click "Performance Options"
  5. Click the button that adjusts windows for best performance (uncheck all buttons)
  6. Click Apply and Exit

Make sure all of your CPU Cores are no parked and are being used (youtube.com/watch?v=4fKxZ1mq9KA)

Make sure to install your GPU Drivers (Nvidia and AMD)

Step 2: In-Game Optimization

Put all graphics on high-ultra except put textures, shadows, viewing distance and post processing on low. This will put more of the load on your GPU rather than your CPU. Also put Anti-Aliasing on Medium-Low.

Set these as your game launch settings, without the brackets: [-high -USEALLAVAILABLECORES]

  1. Go to your Steam Library and make sure WW3 is closed.
  2. Right Click on World War 3
  3. Click Properties
  4. Click on Launch Options
  5. Put Your Settings in and Save
  6. Start World War 3

In the Video Settings, Turn On Motion Blur. This will create the illusion that you are getting more FPS.

I will keep updating this thread when I get more things to add but this is how much I know so far, have fun playing soldiers!

 

 

Edited by Dynshot
  • Like 7
  • Thanks 7

Share this post


Link to post
Share on other sites

I've done those steam launcher settings. I've been getting some weird flickering going on, not sure which one is the culprit. My guess it's the -malloc but I'm not sure it even does anything for a UE4 title. I know it works for ARMA 3

Share this post


Link to post
Share on other sites
27 minutes ago, Devils Never Cry said:

doing this gave me flickering as well so I just deleted the line for me the performance was the same.

I can confirm it's the -malloc line. Got rid of the flickering for me when I removed it.

Share this post


Link to post
Share on other sites

Sorry about the Malloc option, I removed it from the post.

 

On 10/24/2018 at 12:09 AM, Zersorger said:

How do you "downgrade to DX11"?

Removed it from the original post since it's pretty complicated apparently and does not affect it that much,

 

Going to add more stuff in the future and I want to keep adding onto this. If you have any thing that you could add to the thread dm me.

Share this post


Link to post
Share on other sites

i have a i7 7700k@ 4,8ghz an a gtx 1080ti@OC  and 16gb ram ddr4 3000

 

and i play play all high in 4k only shadows on low and view distance ultra but in close fights my fps drops down to 28-35 fps i hope this will be fixed very soon

Share this post


Link to post
Share on other sites

Nice topic , just a few notes : 

From that guide you linked  I noticed you removed -malloc=XXXX , thank god, cause that's a VRengine ( arma ) command and has no effect on UE  I hate seeing being repeated over and over :D

-sm4 ( Shader model 4 ) also ( at least here ) doesn't do anything.
usually on UE you can load -sm4 or -d3d10 , you will load in DirectX10, this game will always load in Dx11.

I could find no diference on -sm4 or not, so I supose it was/is locked ( If anyone can test this , I would be very apreciated )

-maxmem is algo not listed here : https://api.unrealengine.com/INT/Programming/Basics/CommandLineArguments/index.html

A lot of useable commands aren't listed , so it Maxmem MIGHT be a valid command , but I fear like malloc=XXXX it was just a copy pasted command over and over from arma ( https://community.bistudio.com/wiki/Arma_3_Startup_Parameters )  that people just copy-paste repeat.

USEALLAVAILABLECORES is a valid command , but I found almost no diference in my system ( as expected , it should be like that by default ), but better to keep it there , since it will do no harm.

One "option" that does play with the fps is the one frame thread latency:

Quote

On it will render well one frame ahead , thus in some setups giving more fps ( but sometimes causing input latency since frames are being rendered AHEAD of gamethread )

Basically usualy the gamethread waits for the renderthead to sync. ( OTL : OFF ) 

OTL "on" : allows the renderthread to render some frames ahead of the gamethread.

Pros : usually more fps since gpu can render frames ahead of the gamethread
Cons : input latency increases for the same reason.

 

Edited by neolitejukebox
  • Thanks 1

Share this post


Link to post
Share on other sites

the memory usage is utopic now the complett vram from my 1080ti is usage in this game an my system memory usage is about 11-12gb

 

i locked the fps to 100 an my gpu is usage about 80-100% but sometime i have a cpu limit and gpu usage is only 65% IN 4K pls optimised the game its insane that you have in 4k a cpu limit

Share this post


Link to post
Share on other sites

Just saw this from another user and it seems to have helps others including me, doesn't hurt to try. 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, tomciomalina said:

-maxMem doesn't work in ww3

 

6 hours ago, Benni1990 said:

the memory usage is utopic now the complett vram from my 1080ti is usage in this game an my system memory usage is about 11-12gb

 

i locked the fps to 100 an my gpu is usage about 80-100% but sometime i have a cpu limit and gpu usage is only 65% IN 4K pls optimised the game its insane that you have in 4k a cpu limit

 

6 hours ago, neolitejukebox said:

Nice topic , just a few notes : 

From that guide you linked  I noticed you removed -malloc=XXXX , thank god, cause that's a VRengine ( arma ) command and has no effect on UE  I hate seeing being repeated over and over :D

-sm4 ( Shader model 4 ) also ( at least here ) doesn't do anything.
usually on UE you can load -sm4 or -d3d10 , you will load in DirectX10, this game will always load in Dx11.

I could find no diference on -sm4 or not, so I supose it was/is locked ( If anyone can test this , I would be very apreciated )

-maxmem is algo not listed here : https://api.unrealengine.com/INT/Programming/Basics/CommandLineArguments/index.html

A lot of useable commands aren't listed , so it Maxmem MIGHT be a valid command , but I fear like malloc=XXXX it was just a copy pasted command over and over from arma ( https://community.bistudio.com/wiki/Arma_3_Startup_Parameters )  that people just copy-paste repeat.

USEALLAVAILABLECORES is a valid command , but I found almost no diference in my system ( as expected , it should be like that by default ), but better to keep it there , since it will do no harm.

One "option" that does play with the fps is the one frame thread latency:

 

Removed Multiple Launch Commands and Added the Video Settings

Share this post


Link to post
Share on other sites
On 10/23/2018 at 7:11 PM, Dynshot said:

In the Video Settings, Turn On Motion Blur.

I lost faith in you there. Disgusting motionblur.

  • Haha 1

Share this post


Link to post
Share on other sites
42 minutes ago, Skruff94 said:

I lost faith in you there. Disgusting motionblur.

To be fair I know motion blur is not good but in world war 3 it's not insane like other games have it. It was just a tip for people who get around 30fps to make them feel better because it does make the game look smoother with low fps. 😂😂

  • Haha 1

Share this post


Link to post
Share on other sites

Hi there Dyno,

For me personally i have everything on ultra, except for the shadows i do turn on LOW.
For the rest i have "one thread lag"  enabled.

With these settings i get above 70fps permanently with my Geforce 1050ti BUT i do get hickups ingame (screen freezes for a second and then continues).. You think these settings might help?
Perhaps i will try em tonight!

Cheers,
Mike

Share this post


Link to post
Share on other sites
On 10/23/2018 at 7:11 PM, Dynshot said:

WW3 Optimization / Increase FPS Guide October 2018: (Last Edited 10/23/2018)

This guide will help you use your computer to the max to play this amazing new game. In the future the game will be optimized but it's just the beginning now and not everyone has a $3000 system, so this might help a lot of people.

Step 1: Windows Optimization / Hardware Optimization

Install CCleaner and clean everything on your computer. This makes a lot of things fairly easier.

Install Driver Booster (Checks for New Drivers Easily all over your computer)

Optimize Windows 10 for Performance

  1.  Open Windows Explorer
  2. Right Click "This PC" and go to "Properties"
  3. Click "Advanced Settings"
  4. Click "Performance Options"
  5. Click the button that adjusts windows for best performance (uncheck all buttons)
  6. Click Apply and Exit

Make sure all of your CPU Cores are no parked and are being used (youtube.com/watch?v=4fKxZ1mq9KA)

Make sure to install your GPU Drivers (Nvidia and AMD)

Step 2: In-Game Optimization

Put all graphics on high-ultra except put textures, shadows, viewing distance and post processing on low. This will put more of the load on your GPU rather than your CPU. Also put Anti-Aliasing on Medium-Low.

Set these as your game launch settings, without the brackets: [-high -USEALLAVAILABLECORES]

  1. Go to your Steam Library and make sure WW3 is closed.
  2. Right Click on World War 3
  3. Click Properties
  4. Click on Launch Options
  5. Put Your Settings in and Save
  6. Start World War 3

In the Video Settings, Turn On Motion Blur. This will create the illusion that you are getting more FPS.

I will keep updating this thread when I get more things to add but this is how much I know so far, have fun playing soldiers!

 

 

Everyone who has at least 12 GB of RAM and uses a slow SSD can use RAMcache. I suggest using 6 GB RAMdisk. Set the masterdrive to the one where the game is installed. If your game is not on an SSD this will increase performance drastically.

This is the official download link http://dlcdnet.asus.com/pub/ASUS/misc/utils/RAMCACHE_Win7-81-10_V30106.zip 

image.png.802d6f7b201448b0324c19eb28276b9c.png

Share this post


Link to post
Share on other sites

First I tried setting everything to low and the game resulted in the same fps rate as all on ultra.

Then I found this thread and used the launch settings, nothing changed. In best case scenario I get 90 fps, most of the time though it's around 40-50 fps with drops to 20 fps. Especially when you are mid fight and the fps drop that low, you're screwed.

I'm using a GTX 1070 on a Threadripper 1950X running at 2560 x 1440px. Yes, this kind of setup should not result in such poor fps rate.
I'm aware the game is not yet fully optimized but this hardly playable right now. For example in Ghost Recon Wildlands I'm running the same resolution with higher settings at around 100fps.

Would love to hear any suggestions.

Edited by gopgnz
  • Like 2

Share this post


Link to post
Share on other sites
  • the launch options provided in the OP caused me to no longer have stuttering issues after the first minute of the match :D Thank you so much!!!!

Share this post


Link to post
Share on other sites

This hasn't solved any of the extreme stuttering and lag i've experienced with my 4.4Ghz overclocked i5-4690K 16gb of memory, and a evga 1070 sc 8gb set up

Share this post


Link to post
Share on other sites

Did some benchmarking. Start option with -USEALLAVAILABLECORES -high -nomansky -novsync -lowmemory raises minimum fps and 1% low framerate. Little more framerate.

Share this post


Link to post
Share on other sites

Shadows and Post Processing are the most framerate eating setting of the game. Put these on LOW or MEDIUM at the highest. Bumped my framerate right up. I also did a registry tweak to give the process high priority and a memory leak issue(Link to post). Make a backup of your registry and give it a shot, but first try the regular settings. Also make sure your ONE FRAME THREAD LATENCY is enabled

Share this post


Link to post
Share on other sites
On 10/23/2018 at 8:11 PM, Dynshot said:

WW3 Optimization / Increase FPS Guide October 2018: (Last Edited 10/23/2018)

This guide will help you use your computer to the max to play this amazing new game. In the future the game will be optimized but it's just the beginning now and not everyone has a $3000 system, so this might help a lot of people.

Step 1: Windows Optimization / Hardware Optimization

Install CCleaner and clean everything on your computer. This makes a lot of things fairly easier.

Install Driver Booster (Checks for New Drivers Easily all over your computer)

Optimize Windows 10 for Performance

  1.  Open Windows Explorer
  2. Right Click "This PC" and go to "Properties"
  3. Click "Advanced Settings"
  4. Click "Performance Options"
  5. Click the button that adjusts windows for best performance (uncheck all buttons)
  6. Click Apply and Exit

Make sure all of your CPU Cores are no parked and are being used (youtube.com/watch?v=4fKxZ1mq9KA)

Make sure to install your GPU Drivers (Nvidia and AMD)

Step 2: In-Game Optimization

Put all graphics on high-ultra except put textures, shadows, viewing distance and post processing on low. This will put more of the load on your GPU rather than your CPU. Also put Anti-Aliasing on Medium-Low.

Set these as your game launch settings, without the brackets: [-high -USEALLAVAILABLECORES]

  1. Go to your Steam Library and make sure WW3 is closed.
  2. Right Click on World War 3
  3. Click Properties
  4. Click on Launch Options
  5. Put Your Settings in and Save
  6. Start World War 3

In the Video Settings, Turn On Motion Blur. This will create the illusion that you are getting more FPS.

I will keep updating this thread when I get more things to add but this is how much I know so far, have fun playing soldiers!

 

 

This my friends is a copy paste from the internet guide ! All the settings are affecting nothing and using cleaners in 2018 is a funny way to start.

Setting a process to high priority is never a good idea to begin with imho...

CPU parking issues are gone for years but hey it's still valid if you use Windows 7 32 bit !

UE4 has it's problems at the root with AMD hardware ... the only thing for people having issues (mostly AMD users) is waiting for UE4 to get updates and for the devs to implement them here in their engine.

I play on a Ryzen 5 2600 @ 4.2 GHz with 16GB ram and a measly RX580 8GB and I get a decent 60-100 fps.

And thrust me I hate UE4 but it's the cheapest and best game engine an idie company would use ! Look @ Funcom with Conan Exiles the frame rate is ALL OVER the place and vegetation is killing it hard !

These game devs made a MUCH better implementation of UE4 in their game !

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...