Jump to content
Gemini899

[GUIDE] How to Fix stuttering and Improve FPS in World War 3

Recommended Posts

7 hours ago, DIR3WOLF said:

Going to give this a shot when I get back home in a bit. Thank you

I've done everything,folowed everything and the last part ,,HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Ndu'' 

I found everything except that Ndu,nowhere to be found :)

Share this post


Link to post
Share on other sites

So ran with this while recording as well, fuk me its worse.

Share this post


Link to post
Share on other sites

Well I don't know which one of the two did it (your registry edits or the new update) but my fps is buttery smooth now an entire match. Hitting 120fps indoors going down to 80-90 in open areas but that's to be expected.

Share this post


Link to post
Share on other sites

as an option you can try GameUserSettings.ini

 

[/Script/Engine.RendererSettings]
r.Streaming.Boost=0
r.Streaming.PoolSize=0
r.Streaming.LimitPoolSizeToVRAM=1
r.Streaming.DefragDynamicBounds=1
r.Streaming.HLODStrategy=2
r.Streaming.FullyLoadUsedTextures=1
r.bForceCPUAccessToGPUSkinVerts=True
r.CreateShadersOnLoad=1
r.Shaders.Optimize=1
r.Shaders.FastMath=1
r.UseShaderCaching=1
r.UseShaderPredraw=1
r.TargetPrecompileFrameTime=13
r.PredrawBatchTime=13
r.AccelPredrawBatchTime=0
r.AccelTargetPrecompileFrameTime=0
r.Streaming.FramesForFullUpdate=60
r.FinishCurrentFrame=0

Share this post


Link to post
Share on other sites

@DarkEmpire added your to my config:

 

[/script/Engine.RendererSettings]
r.DefaultFeature.MotionBlur=False
r.LightFunctionQuality=0
r.ShadowQuality=0
r.Shadow.CSM.MaxCascades=1
r.Shadow.MaxResolution=256
r.Shadow.RadiusThreshold=0.1
r.Shadow.DistanceScale=0.6
r.Shadow.CSM.TransitionScale=0
r.DistanceFieldAO=0
r.DepthOfFieldQuality=0
r.RenderTargetPoolMin=300
r.LensFlareQuality=0
r.SceneColorFringeQuality=0
r.EyeAdaptationQuality=0 
r.BloomQuality=0
r.FastBlurThreshold=0
r.Upscale.Quality=1
r.TonemapperQuality=0
r.LightShaftQuality=0
r.TranslucencyLightingVolumeDim=24
r.RefractionQuality=0
r.SSR.Quality=0
r.SceneColorFormat=3
r.TranslucencyVolumeBlur=0
r.MaterialQualityLevel=0
r.SSS.Scale=0
r.SSS.SampleSet=0
r.Streaming.Boost=0
r.Streaming.PoolSize=0
r.Streaming.LimitPoolSizeToVRAM=1
r.Streaming.DefragDynamicBounds=1
r.Streaming.HLODStrategy=2
r.Streaming.FullyLoadUsedTextures=1
r.bForceCPUAccessToGPUSkinVerts=True
r.CreateShadersOnLoad=1
r.Shaders.Optimize=1
r.Shaders.FastMath=1
r.UseShaderCaching=1
r.UseShaderPredraw=1
r.TargetPrecompileFrameTime=13
r.PredrawBatchTime=13
r.AccelPredrawBatchTime=0
r.AccelTargetPrecompileFrameTime=0
r.Streaming.FramesForFullUpdate=60
r.FinishCurrentFrame=0

 

Share this post


Link to post
Share on other sites

Anyone knows how to reach more than 60 fps? ....i disabled the fps limit on options and follow all the instructions on this treahd and the game keep the fps cap on 60..(im sorry for my basic and horrible english)

Share this post


Link to post
Share on other sites

I have the feeling the performance got way worse than couple of days before. Last week i was able to play at almost constant 60-70fps. sometimes it was a bit more even up to 100fps, on problematic scenery like open field berlin or moscow fps dropped to ~35.
Today i played two matches after four days and my game doesnt feel es fluid as before. It seems like the performance is worse, game is stuttering, lags, teammates rubberbanding etc. Worthermore the graphics look worse than last week. Dont know what happend, but at this state the game becomes more and more unplayable.

  • Like 2

Share this post


Link to post
Share on other sites

hm, i also did all tweaks what are mentioned, first it felt like a boost, but my game is still stuttering too often and tbh i cannot play propery this way. 
I don't understand the problem, is it the textures or what? I run on a Omen Laptop with GTX1070, 16gb ram, SSD etc.. so with loading and all that i have no issues. 
But the ingame performance is just not very good, i can play, sure, but the micro lags all the time make it worse. 
I ask myself how the authentication Server can cause this??? 
This is only for the connection issues, but why do some seem to be able to play with everything runs very smooth, but others don't?!

If there is nobody around i have no lag at all, so i think the netcode is the problem, but if this would be the case nobody would be able to experience a smooth gameplay. 
actually i get frustrate, because of the bad performance :(

Share this post


Link to post
Share on other sites

me too have more problems in these days of frame rate and stuttering than before, I think it is something inherent in the frequency refrash in the  servers

Share this post


Link to post
Share on other sites

We need to have a proper review from battle(non)sense https://www.youtube.com/channel/UCP7QY6L5pvmm0-stL-pNFrw regarding to our WW3. It's an early access game and we as players need to understand and give more time to dev team, but should at least give us their priorities and a roadmap with next steps, like optimization issues is top priority? and when can we expect to have patches or better servers (1 month, 2 months,...) the community need to have this kind of metrics, know when and what changes are being made, because we have a word to say if they are working in less important features to majority of players. For me is optimization that need to be addressed as quick as possible, make what we have so far stable and enjoyable.

 

DEV TEAM please give as a roadmap! Also create a post specific for this subject and post frequently in twitter because is a fast way to spread word and make players come more often to this roadmap post to check news regarding to is being made.

 

Thanks. By the way i love to combine in my setup G39 sniper rifle and G36 assualt rifle, it's the first time i can switch my gameplay during a "life". i thick this kind of freedom is cool because we can defend from far position and if necessary get close quarters defense position. Nice work!   

Edited by morphine

Share this post


Link to post
Share on other sites
7 minutes ago, morphine said:

We need to have a proper review from battle(non)sense https://www.youtube.com/channel/UCP7QY6L5pvmm0-stL-pNFrw regarding to our WW3.

You can approach him on Twitter/Youtube. He is responding to questions and requests there. He would need a copy of the game to test it. Also note that he is doing network analyses of video games and not "performance" analyses in regard to how much fps you get and if the game stutters etc.

I can tell you that optimization is a ongoing process and usually the most progress is made in the later stages of development. Its not easy to optimize a game when a lot of the content is not in place.

Edited by Schlagerfreund
  • Like 1

Share this post


Link to post
Share on other sites

I follow batlenonsense and saw a post in twitter were we wrote that will release a video with WW3 netcode analysis. So it's a question of time for us to get a proper analysis. Related to optimization i still think that is mandatory to stabilize the gameplay and do everything possible to address the issues that we have in present, since they are preventing players from have a nice experience playing the game and this is preventing player base from growing. I like the game but to play everyday the gameplay must improve an be more enjoyable. You understand what i am trying to say, right? :) 

Share this post


Link to post
Share on other sites
1 hour ago, Schlagerfreund said:

You can approach him on Twitter/Youtube. He is responding to questions and requests there. He would need a copy of the game to test it. Also note that he is doing network analyses of video games and not "performance" analyses in regard to how much fps you get and if the game stutters etc.

I can tell you that optimization is a ongoing process and usually the most progress is made in the later stages of development. Its not easy to optimize a game when a lot of the content is not in place.

 

This already have been made by someone much important than me in the gaming community :)

  • Angry 1

Share this post


Link to post
Share on other sites
22 hours ago, Gemini899 said:

@morphine ye but why you are spamming this on mine thread create a new topic.

On your thread?!?!? It was just for sharing... wtf strange ppl. Stay with your thread for your self. 

  • Angry 2

Share this post


Link to post
Share on other sites
On 10/26/2018 at 3:55 PM, Prycol said:

What's od the standard value for start on ndu? When i did it my system started to reseting

 

NDU's default "start" value is 2

Share this post


Link to post
Share on other sites

cause a lot of the problems are still server related i play most of the time on the "small" versions of the maps, runs much better with 32 than with 64 players !

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...