Jump to content
Stundorn

60+ FPS, but stuttering

Recommended Posts

Hi,  my games still stuttering,  no matter the graficsettings and i constantly have 60 fps. 

The fact that bothers me is that a friend with an older gtx 960 can run it completely smoothly with all setting on ultra. We both have i7 6700 and 16gb DDR3 plus game on ssd. I run a gtx1070 he's runs a 960.

He said yesterday after he just installed it and tweaked nothing that it runs absolutely fine. No lag, no stutter, just fine and smooth.

What i tried until:

Registry tweak for CPU prioritization

Recommended Grafik settings from the forum plus a lot of similar  combinations tested.

Tweaked gameusersettings.ini 

Tweaked Nvidia control panel settings

Mostly the game runs very well in the beginning,  even with other Soldiers,  no lag,  but the moment the battle begins it becomes stuttering. 

Sometimes i have no stuttering for several seconds,  even if i'm in the Building in Moscow or in front of the Brandenburger Tor with lots of players and Action around. Some seconds it's all fine,  then it begins to stutter again.

I cant say if it's grafics or network or both. 

Sometimes i think it only can be network issues,  because it sometimes just runs fine even with everything on ultra.

Seems many people can play without any stutterings.

Others cannot play at all and i can play,  i have progression and all config saved, but i have these stutterings what dont make it completely unplayable,  but it drives me nuts tbh.

And i dont understand why!

What i just did was this:

Opened console as administrator

At prompt write:

bcdedit /deletevalue useplatformclock 

bcdedit /set displaydynamictick yes

I hadn't much time to test since i did that,  but i had less stuttering,  but i need to validate this by more testing. 

What i can say is: the stuttering is not completely gone,  but first tests show me it's significantly better.

To reverse this you can open console as administrator again and write

bcdedit /set useplatformclock true

bcdedit /set displaydynamictick no

Please google for further Information about Boot Configuration Data and HPET (high precision event timer).

So, you will find people say it's good to enable it if HPET is enabled in BIOS and OS (by using the command) and other people say disabling this helped with microstuttering in games.

I am not sure about this,  but it reduced stutterings for me at the moment. 

I need to test that further,  because some Matches run better than others for me and i already played 30+ hours with stuttering so i am somewhat used to have it and when testing you need to go into the action,  because spawnzone or less crowded areas are mostly fine. 

People with stuttering although they have 60+ FPS please share your experiences and tweaks. 

Thanks. 

 

Edited by Stundorn

Share this post


Link to post
Share on other sites

I had a lot of stuttering, then I read a post here advising to disable toggle to sprint. I did it and stuttering was gone.

I was really disappointed with the amount of jerkiness there was, but that completely solved it for me.

I don't know why, but it was the solution to my problem. Try it...

 

Share this post


Link to post
Share on other sites

Will follow your thread and will take a look at those settings at home, will be waiting for your updates !

 

7 minutes ago, nunbar said:

I had a lot of stuttering, then I read a post here advising to disable toggle to sprint. I did it and stuttering was gone.

I was really disappointed with the amount of jerkiness there was, but that completely solved it for me.

I don't know why, but it was the solution to my problem. Try it...

 

 

Really ? Will try that tonight !

Share this post


Link to post
Share on other sites

So, i tried 2 games with above bcdedit settings and it's far less stuttering, but not completely gone. 

I then turned toggle for running of and enabled on hold  an the stuttering was completely gone, i may have seen it lagged one time, but this was clearly some mermory leak and just happened once. 
I thought it was all the running toggle and turned HPET on again - btw i made a mistake about dynamic ticks, the correct setting is

bcdedit /set disabledynamicick yes (and not displaydynamic... sorry)

but then the mouse stutters in the menu alright, what was new and left me a little confused. 
So i turned it off again (bcdedit /deletevalue useplatformclock) and keep running on hold. 

All fine, all on ultra

Share this post


Link to post
Share on other sites

Always disable HPET in the bios!

 

Overclock the 6700k to the maximum if possible, and you will see an improvement, if not already overclocked that is..

 

Also, have you tried a clean install of windows 10 already? if i have bad stuttering, i immediately do a clean install of windows(doesnt take that long) en retest the game from there.

 

Edit :  I noticed you don't have the 6700K edition?

Edited by ill

Share this post


Link to post
Share on other sites

My rig:

R7 2700x 
1080 ti 11Gb
16Gb DDR4

I noticed that when a match starts, everything seems okay. Okay, my GPU usage is somewhere in the 65-70% (I blame optimization for this), but I get a 100+ FPS on 2k resolution at Ultra.
During the game however my FPS is gradually lowered while GPU and CPU usage remain the same. They have a lot to work on when it comes to engine optimization and I believe they are focusing on this after master server issues are fixed.

 

Happy gaming!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...