Jump to content
Sign in to follow this  
rawalanche

Unable to play - Sound comes from Rift earphones

Recommended Posts

DESCRIPTION OF BUG Sound comes from Oculus 

GAME BUILD ID 3343723

DESCRIPTION OF BUG:

I am no longer able to play the game as sound comes only from the Oculus Rift earphones, despite default Windows Audio device is correctly set to regular speakers. Turning off autodetect device in audio settings doesn't help, and audio device option has only one setting - main, which can not be changed.

 

Share this post


Link to post
Share on other sites
6 hours ago, weedtime said:

I'm not really in VR settings, but did you try this?

 

Just tried, did not work. I don't actually have problem with SteamVR launching when I start the game. It happened in some of the previous build, but it doesn't happen anymore, so I don't think it's SteamVR related at all. Even with -nohmd launch option, the sound still only comes out of oculus earphones.

Share this post


Link to post
Share on other sites

I don't think so the problem is related to the game, did you try on different games, it's the same issue?

Share this post


Link to post
Share on other sites
On 12/12/2018 at 12:21 PM, weedtime said:

I don't think so the problem is related to the game, did you try on different games, it's the same issue?

No, absolutely every single game and Windows application on Steam and outside Steam works flawlessly. Sound comes from my Speakers, which are set as Windows primary audio device. The issue is clearly related to initialization of Oculus VR libraries bundled with Unreal Engine 4.

I am still unable to play the game.

Edited by rawalanche

Share this post


Link to post
Share on other sites

Did it start happening after a certain patch or just from day by day? If from day by day, there has to be something with device outputs in Windows, Steam etc.

Open your "playback devices" menu and make sure your non-rift audio is a default. If you use StamVR, make sure you have both the "When SteamVR is active" and "When SteamVR has exited" settings set to their appropriate devices.

Also, you can create a topic in this section of the forum, maybe some players might be helpful https://forum.worldwar3.com/index.php?/forum/59-help-center-from-players-for-the-players/

Also, did you try PTE update? Maybe some files are missing, dunno.

I will report it.

Share this post


Link to post
Share on other sites
On 12/14/2018 at 5:28 PM, weedtime said:

Did it start happening after a certain patch or just from day by day? If from day by day, there has to be something with device outputs in Windows, Steam etc.

Open your "playback devices" menu and make sure your non-rift audio is a default. If you use StamVR, make sure you have both the "When SteamVR is active" and "When SteamVR has exited" settings set to their appropriate devices.

Also, you can create a topic in this section of the forum, maybe some players might be helpful https://forum.worldwar3.com/index.php?/forum/59-help-center-from-players-for-the-players/

Also, did you try PTE update? Maybe some files are missing, dunno.

I will report it.

I'm in the same boat, there is no sound at all coming from headset or speakers, just from the Oculus rift. 

This is the only game with this problem, the others works fine.

 

Edit: I guess that this issue is not only for Rift users.

 

https://steamcommunity.com/app/674020/discussions/0/3104564981102215749/

 

https://steamcommunity.com/app/674020/discussions/0/1744479698803088975/

 

 

 

Edited by IIJackoII

Share this post


Link to post
Share on other sites

Sorry if you have already done this : did you try to first launch the game and then set the loudspeaker as primary?

Also try playing around with the checkbox in the advanced settings in that area specifically "applications have control over this". 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...