Jump to content
ample12

game stuck at loading screen

Recommended Posts

 Yesterday i started to play ww3  and i have spend  5 hours  trying to get this game to work, but i never got past the connecting to ww3 server. is there a fix for it ?

sorry for the bad english :)

my pc:  i5 8400k, 1050 ti , 8 GB of ram, 1 tb hard drive,

i have tried downloading the game 2 times, i have verifyed the files, used different servers and closed my virus protection off 

Edited by ample12
new information

Share this post


Link to post
Share on other sites

Hey!

It seems like a few players still experience connection issues, did you already try these things?

  • connecting to different regions
  • Verifying files (right click on WW3 in steam < properties < local files)
  • Reinstalling the game
  • disabling antivirus/firewall

Share this post


Link to post
Share on other sites

I have the same problem. Game hangs on map loading screen. 

It seems like map is loaded, but screen didn't changed  (I can hear sounds of battle) 

  • connecting to different regions

Tried to connect to NA and it works. Looks like only EU servers suffering this issue. 

  • Verifying files (right click on WW3 in steam < properties < local files)

Always couple files needs to be redownloaded (6-8)

  • Reinstalling the game

Last resort.. didn't checked it yet. 

  • disabling antivirus/firewall

Doesn't seems to be the issue while other regions works. 

 

 

Edit: Looks like issue I see is described in different topic:

 

Edited by PikNick
found issue that fits better in my case.

Share this post


Link to post
Share on other sites
1 hour ago, PikNick said:

I have the same problem. Game hangs on map loading screen. 

It seems like map is loaded, but screen didn't changed  (I can hear sounds of battle) 

  • connecting to different regions

Tried to connect to NA and it works. Looks like only EU servers suffering this issue. 

  • Verifying files (right click on WW3 in steam < properties < local files)

Always couple files needs to be redownloaded (6-8)

  • Reinstalling the game

Last resort.. didn't checked it yet. 

  • disabling antivirus/firewall

Doesn't seems to be the issue while other regions works. 

 

 

Edit: Looks like issue I see is described in different topic:

 

Hey!

The developers will look into this again.

Share this post


Link to post
Share on other sites
23 hours ago, quitshii said:

Hey!

It seems like a few players still experience connection issues, did you already try these things?

  • connecting to different regions
  • Verifying files (right click on WW3 in steam < properties < local files)
  • Reinstalling the game
  • disabling antivirus/firewall

Yes, many times

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...