Jump to content
Sign in to follow this  
spl1ffa

Server performance

Recommended Posts

I wonder if the current server performance is good enough? A typical sign of a stressed server is skyrocketing latency when many connections establish. I can experience this on almost any match. If there are 10 people are on the server, ping is usually at around ~50 ms (if lucky), as soon as the server gets full it spikes up to 80 ms or even over 100 ms. As latency is a key component in FPS games to enjoy them, I would like to see pings constantly on the same level, independent on how many players are connected. Also, lately the server performance symbols on top left popping up more often (I assume they display server performance problems and loss?)

I think in general, latency to ww3 servers are too high. I know, I am spoiled by my fiber connection and the excellent peering of my provider. I live in central Europe and normally I get pings of 8-30 ms in shooters like BF4 or BF1. Also pings to i.e. Frankfurt (de-cix) are never higher then approx. 30 ms. Even London is not that much higher.

Share this post


Link to post
Share on other sites

The latency you see is not strictly ping value, it's ping + frame time + some other latencies added. You'll be able to see the real ping once the server browser is added (on PTE this week) or use the Steam server browser which also shows the ping values, not latency.

Server performance is also not that great at the moment, this is why we don't have bigger matches (yet). With 4.21 switch and Replication Graph + some other optimization we're currently working on, it should be better.

Now, my question is, do you feel the difference, or is this just the value that's worrying? I ask, because we run 60hz servers with 100hz client sendrate, which bombards the servers, but at the same time, we send out stuff when it's ready, not waiting for the end of the frame, so real life delays are lower than show up in the corner.

You can get a bit more info in the Battlenonsense's video about it, our delays are comparable to other shooters and beat some of them:


image.png

Link to the video: 

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Ragir said:

Now, my question is, do you feel the difference, or is this just the value that's worrying? I ask, because we run 60hz servers with 100hz client sendrate, which bombards the servers, but at the same time, we send out stuff when it's ready, not waiting for the end of the frame, so real life delays are lower than show up in the corner.

I'm not really bothered by the number in the top left. But every time the game feels laggy, sluggish or choppy the latency in the top corner is >80 ms. When the server is only half full, and the latency is around 40-50 ms, the game response is so much more snappy and thus more enjoyable.

Perhaps many of the other players won't notice this, because they have (massive) performance problems with their rigs and / or living far away from the servers. I have to admit, that my system is coping really well with ww3, I have quite stable fps of ~120 most of the time, so I may notice the increase of the latency more than others.

  • Like 2

Share this post


Link to post
Share on other sites

Its possible that high framerate makes it easier to notice other problems, so this might be the case here. In either case, thanks for the report, as I said we are not happy or done with serverside optimization, so signals like this help us prioritize the work better.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for your feedback. As soon the server browser will be available, I will do some testing with specific server IP's (i.e Frankfurt servers) to gather more data on this topic.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, spl1ffa said:

As soon the server browser will be available

It's available on PTE right now :)

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

UPDATE after we play few rounds in PTE,

OMG !!

OK before I rage on it .

Thank you for those fixes, we saw them and for the server browser , nice !! needs work ,  but it works !!

NOW !!

The GAME  CONTINUE CRASHING !!

And now we got really bad FPS 33 - 29- 55- 50- 48   !!! and a HORRIBLE LAG !!! and the stutter came back !!

Still the sound !  cannot pin point the enemy correctly .

Tank you for the effort but Cmon !!  CTD 's all the way !!

:(

HALCON4 - WW3 - k4to01

Edited by HALCON4
text

Share this post


Link to post
Share on other sites

Feels bad man. :( I had absolutely no problem yesterday. Also the frames were quite fine. But I think it's been announced somewhere that more fixes are supposed to arrive soon. Hope it gets better for you soon. 

  • Thanks 1

Share this post


Link to post
Share on other sites

HI HeiligeRobbe thnsk man !! , I know, it feels bad to CTD in  the middle of battle an dhave that stutering lag  again. :(  But FARM 51, they are aware of the sitrep now. :)

We send our reports now and they are experiencing same on their system .

We are in process to finish building the new rigs for the team , with brand spanking new 2060 Nvidia cards and the new AMD Vega 64, we have so far Crashes and bad FPS with the new 2060 and 32 Gigs of ram !

2 systems that we just finished building just got CTD's and the other ones left with 1080 -1070  Nvidia as well CTD'S,

But... ! at the end of weekend, will have all the Rigs ready for test this new PTE , AGAIN and check benchmarks and Optimization of this new PTE patch, and return with feedback.

Thanks again FARM51 for keep trying hard to fix this WW3 !!

 

HALCON4 - WW3 - k4to01

 

  • Like 1

Share this post


Link to post
Share on other sites

I like the new server browser. It needs some polishing but so far a very good addition. In the future, I would like to be able to see server details (i.e right click, then you see IP, player list and so on) and secondly, to open the server browser during a running game, so you can search a new game and (possibly) queue up if server is full.

Performance-wise I'm quite happy with the current PTE, I had the impression that there was more stuttering but no CTD so far and frames were over 100 most of the time.
Not sure why my system barely ever crashes, but hey, I take it ?. I'm really sorry for all others tho.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...