Jump to content
FoxFort

Endless stuttering with v0.5

Recommended Posts

Posted (edited)

DESCRIPTION OF BUG:
This is my experience with WW3, it's been like this for some time. Version 0.5 is unplayable, regardless how many players are ingame or visuals details I play on. The previous 0.4 was better, not great but better than 0.5 for me, performance wise.

GAME BUILD ID: 3705486

STEPS TO REPRODUCE: All the time

SYSTEM SPECIFICATIONS : CPU i7-7700HQ; RAM: 16GB DDR4; GPU: GTX1050 4GB; HDD: SSD

 


SORRY FOR BAD AUDIO QUALITY, I forgot to disable my microphone.

Edited by FoxFort

Share this post


Link to post
Share on other sites

We know about it, why don't you jump and try PTE client, until 0.6 hit live servers, there is no shuttering problem. Remember, PTE servers are located in the EU.

Share this post


Link to post
Share on other sites
Posted (edited)
9 hours ago, weedtime said:

We know about it, why don't you jump and try PTE client, until 0.6 hit live servers, there is no shuttering problem. Remember, PTE servers are located in the EU.

I've tried PTE today and I've experience a bit better performance. When there is a low number of players on server (both type of games), the game stutters a bit less but if map is almost full, it's unplayable for me. I'm in Prague and I play on EU servers only.  The game performance was much better for me with v0.2 and v0,4 versions, as with current v0,5 and PTE 0.6, It's worse.
My CPU is not being fully used, it's client - server communication thing. Because when I'm on empty map, it's all smooth. I am not having this kind of issues in other games I play, e.g. Squad or Arma3.

Edited by FoxFort

Share this post


Link to post
Share on other sites

Even if one of your cores hit 100% usage it will drop your CPU clock, so you need to monitor all of your 8 cores, also 1050ti isn't very powerful, to be honest, it's a laptop, and even people with PC's encounter problems with 1050ti's. We still optimizing the game, however, this progress will be ongoing until full release as we don't need additional work during this progress, but we have a team which takes care over the optimization, but it will not be done as good as when the game will be finished. Your laptop runs fine when the server is empty, but when the players start joining, there is much more to be calculated trough CPU and GPU, that's why you will encounter performance issues.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, weedtime said:

Even if one of your cores hit 100% usage it will drop your CPU clock, so you need to monitor all of your 8 cores, also 1050ti isn't very powerful, to be honest, it's a laptop, and even people with PC's encounter problems with 1050ti's. We still optimizing the game, however, this progress will be ongoing until full release as we don't need additional work during this progress, but we have a team which takes care over the optimization, but it will not be done as good as when the game will be finished. Your laptop runs fine when the server is empty, but when the players start joining, there is much more to be calculated trough CPU and GPU, that's why you will encounter performance issues.

Yeah I agree, my 1050 is an entry level GPU so I'm never expecting great performance. I would not "blame" it all on my not so good hardware, since Squad and Post scriptum (same engine as ww3) with 80 players and bigger maps perform far better on my laptop on high details than WW3. So it's not just my hardware. Also WW3 v0.4 was performing better for me. 

WW3 is still in BETA or ALPHA, so I'm not expecting it to be fully "polished", the game has just becomed unplayable on my end and it's not only because my HW is "cheap".  

Is there anyway I can help you guys, by running some benchmark or create some logs that will show you whats creating stuttering? (Even when I'm on LOW details).

Edited by FoxFort

Share this post


Link to post
Share on other sites

There is not much you can do to help us at this moment, Squad is in development past 3 years, Arma III 6 years. About Post scriptum looking at the gameplay players don't get more than 60 FPS with decent PC configuration. We are 5 months in development - from the time when the game started in the early access phase, still, a lot to be done, the optimization is one of the priorities but it's gonna take time before the game will be running flawlessly. We know what was causing stuttering in 0.5 and it was eliminated in 0.6 patches and for me personally, 0.6 runs much better than when I was playing in 0.4, rest is on your end. We also planning to move on the newer UE4 engine end at this moment reworking animation system which helps gain better performance. Release date is planned for late 2019/early 2020, give it some time and with time it will be better ?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...